NewPost ┃Tree ┃Thread ┃Plain ┃Topic ┃Search ┃Setting ┃Top  
50 / 307 ツリー ←次へ | 前へ→

A few requests (display) geoslake 09/1/21(水) 21:18
Re:A few requests (display) granz 09/1/22(木) 3:29
Re:A few requests (display) Jezze 09/2/2(月) 7:07
Re:A few requests (display) granz 09/2/3(火) 17:34
Re:A few requests (display) Jezze 09/2/4(水) 5:08
Re:A few requests (display) granz 09/2/4(水) 7:05

A few requests (display)
 geoslake  - 09/1/21(水) 21:18 -
hi sir

First, thank you very much for your amazing Snesgt emulator !
A few things :

- Could you add more window sizes ? 2x is too small to me, while x3 is a bit big. Things like 2.5 etc would be nice imho.

- Could you consider supporting mame rgb masks system ? These are simple png displayed over the image, and it gives great results while using no cpu at all. It's called "mame overlay effects".

- Could we have more configurable scanlines ? Actually, with the right settings, bilinear + scanlines can look great. Nestopia, using 30% scanlines + interpolation, looks much smoother than snesgt.
(i guess the % thing is for scanlines brightness...)


Re:A few requests (display)
 granz E-MAIL  - 09/1/22(木) 3:29 -
Also, could we get more filters, or a more extensive configuration for filters? I've noticed that using anything besides the normal filter causes significant slow-down.

Re:A few requests (display)
 Jezze E-MAIL  - 09/2/2(月) 7:07 -
SNESGT is compatible with the filter plug-ins from the very old VirtuaNES2 pre-alpha 2 release and supports Kega Fusion filters. Unfortunately not all filters seem to work with the current beta of SNESGT, but most.

Re:A few requests (display)
 granz  - 09/2/3(火) 17:34 -
Thanks for the suggestion. None of these improve emulation performance, or get rid of the default "bilinear" filter that seems to be imposed when you turn off filtering altogether.

I would like to run the emulator without any filters, and see the game with full pixelation intact. How can I achieve this?

Re:A few requests (display)
 Jezze E-MAIL  - 09/2/4(水) 5:08 -
Sounds like a driver issue to me.

Some graphics card drivers do filter the video output by default, other drivers do not. On my XP system I'm using the ForceWare drivers 71.89 for an old GeForce and the video output is bilinear filtered by default. On my Vista system I'm using the ForceWare drivers 188.22 and the video output is not bilinear filtered by default, not even if I activate the bilinear filtering.

Do you get a filtered video output, if you use the "nearest neighbor" filter? On both of my systems, I get a clear unfiltered output with this filter.

Unfortunately I have no solution for your performance problem. As long as I have no high-performance filter like "NTSC" in use, the frame rate almost never drops below 60.

Re:A few requests (display)
 granz  - 09/2/4(水) 7:05 -
Thanks for your response.

I initiailly thought it may be the way my card drivers handle DirectDraw, but I've done a lot of research, and this doesn't seem to be the case. I'm running an ATI Radeon 9200 with the Omega third-party drivers.

Also, you mentioned Vista versus XP. Actually, DirectDraw is only emulated in Vista, and this is why you don't see the bilinear effect. If you disable DD acceleration in XP, (in other words, you make DD emulated) then it will have the same effect -- there will no longer be a bilinear filter in place. However, many games / emulators require DD acceleration to run in the first place. Disabling it means I can't use most of my emulation software any more.

As far as I can tell, this is something exclusive to DD itself. I think DD mandatorily imposes this filter, and there is simply no way to deactivate it. That's why I requested that the author of SNESgt add Direct3D or OpenGL rendering support. Using either of these rendering methods always gives me a clearer image without the filtering effect.

  NewPost ┃Tree ┃Thread ┃Plain ┃Topic ┃Search ┃Setting ┃Top  
50 / 307 ツリー ←次へ | 前へ→
ページ:  ┃  記事番号:   
(SS)C-BOARD v3.5.4 is Free.